Shader Forge 1.26 is now released!

User avatar
Acegikmo
Neat Corp / Admin

PostTue Dec 08, 2015 8:58 pm

• Fixed a bug where PBR shaders didn't compile in Unity 5.3
• Fixed a bug where TextureAsset didn't respect its Tiling & Offset parameters
• Fixed a bug where you couldn't use the same node in tessellation and displacement at the same time

In addition, the PBR shaders will not completely match Unity's shaders as of 5.3 due to them switching to the GGX model. This will come in a later update next week!
Marco Sperling
Shader Forge Moderator
Location: Germany

PostWed Dec 09, 2015 8:00 am

I really hope this whole GGX-switch finally fixes Substance Painter /Designer compatibility issues. Therefore I am looking forward to 1.27 eventually.
User avatar
Acegikmo
Neat Corp / Admin

PostWed Dec 09, 2015 8:03 am

Is there a visual or technical compatibility problem in this case?
Marco Sperling
Shader Forge Moderator
Location: Germany

PostWed Dec 09, 2015 8:16 am

There has been a visual difference between how roughness/smoothness looks in SP/SD compared to how it looks in Unity because of the different lighting equations used.
SP uses the GGX BRDF. Unity had its PBR based on a Blinn-Phong BRDF. So things were slightly off. 5.3 should hopefully make this a thing of the past.
gevarre

PostFri Dec 18, 2015 12:15 am

Okay, so I just downloaded the latest version, and it says it's 1.18. Did you upload the wrong one, or is there a lag with the asset store or something?
User avatar
DMeville
Shader Forge Moderator
Location: Canada

PostFri Dec 18, 2015 2:19 am

@gevarre, Make sure you've downloaded Unity 5.3!
gevarre

PostFri Dec 18, 2015 11:47 pm

Aha! I guess that would do it. Thanks.

It was just confusing because neither this thread, nor the notice that keeps popping up in Unity say 5.3 is required. Even the asset store page just says it requires Unity 4.5 or higher.
User avatar
Acegikmo
Neat Corp / Admin

PostSat Dec 19, 2015 8:29 am

This is something Unity should have built-in in their asset store system, there's currently no proper way to get information about version compatibility and even local asset version, so I'm doing this manually now.
Unity's asset store says "requires Unity 4.5 or higher" because there is still an older version of SF for Unity 4.5 that is actually supporting it (1.06).

That being said, I can improve it by updating the code in SF itself to notify you that you're on an old version, but it wouldn't be retroactive, so people using the older versions will still have the same issue.

For the most accurate versioning information, I recommend heading to the changelog! I always try to keep that one up-to-date whenever a release requires an update. (Look at 1.06, 1.18, 1.25)

Return to “Announcements”



Who is online

Online users: No registered users and 1 guest